package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,3}\.){3}\d{1,3}`)
var str = `95.108.170.149
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}