import Foundation
let pattern = #"^(?:0\.0*|[+-]?(?:(?!0\.0*$)0|[1-9][0-9]*)?\.[0-9]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
float varieties:
4848.48
20.20
20.2000000
-1.23
-0.23
+1.1
0.45
+0.45
-0.45
0.0
0.00000
-0.0
+0.0
.3
-.4
+.4
+.30
00.1
+00001.1
01.45
+01.20
-00.2
int varieties:
1234
43210
12012
+1
0
-0
+0
01234
000001234
+00
-00
+00123
-00123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)