import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d{1,3}(?:(?:,\\d{3}){0,4}(?:\\.\\d{1,2})|(?:(?:\\s\\d{3}){0,4}|(?:\\d{0,12}))(?:[.,]\\d{1,2})?)$";
final String string = "123456\n"
+ "123456.12\n"
+ "123456,00\n"
+ "123,456.12\n"
+ "123,456,12\n"
+ "123 456.12\n"
+ "123,456,12\n"
+ "123,456,123,123,123.00\n\n"
+ "123,456.123\n"
+ "123 456,789.12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}