re = /(\w)(?:(?=(?:.*?\1){4})|(?=(?:(?!\1).)*(\1)(?:(?!\1).)*(\1)(?:(?!\1).)*(\1)(?!.*?\1)))/
str = 'abcdbcdcdd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end