re = /# Keys are pretty much "any text before the '=' symbol"
(?P<key>[^=]+)
# Match the '=' symbol
=
(?P<value>
# Lazy match
.*?
# Look-ahead (don't move the "regex cursor", just "peek forward")
(?=
# Match a '_' that has no other '_' between it and the '=' character, or...
_[^_=\n]+=
|
# ... or the end of the line
$
)
)
# Actually "consume" the '_' character if it exists (or just match the end-of-line)
(?:_|$)/mx
str = 'str=string_number=12345_device=phone_color=blue
color=aqua_marine_name=matt_number=123_456_879_lastname=blahblah'
subst = '\\1 = \\2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result