$re = '/(.*online\.cuw\.edu\/.*(online\-education\-degrees|masters\-degree\-education|.*master\-of\-science\-in.*|.*masters\-of\-science\-in.*|programs\/graduate\/(educational\-leadership|literacy|special-education|teaching\-learning))|.*onlineinfo\.cuw\.edu\/(go\/(7\-key\-ideas\-lutheran\-school\-administrators|career\-consultation|curriculum\-instruction|education\-(degrees|technology)|educational\-leadership|educator\-quiz|general\-accelerated|ms\-(counseling|education\-literacy|educational\-administration|special\-education|teaching\-and\-learning))))\/|.*www\.cuw\.edu\/(programs\/(ed\-admin|educationtech|familystudies|literacy|specialeducation|teachlearn)\/index\.html)|.*onlineinfo\.cuw\.edu\/strengthsfinder\-for\-teachers/';
$str = 'http://online.cuw.edu/areas-of-study/online-education-degrees/
http://online.cuw.edu/areas-of-study/online-education-degrees/masters-degree-education/
http://online.cuw.edu/online-degrees/master-of-science-in-curriculum-instruction-msci/
http://online.cuw.edu/online-degrees/master-of-science-in-education-leadership/
http://online.cuw.edu/online-degrees/master-of-science-in-education/
http://online.cuw.edu/online-degrees/master-of-science-in-education/counseling/
http://online.cuw.edu/online-degrees/master-of-science-in-education/education-administration/
http://online.cuw.edu/online-degrees/master-of-science-in-education/educational-design-technology/
http://online.cuw.edu/online-degrees/master-of-science-in-education/literacy/
http://online.cuw.edu/online-degrees/master-of-science-in-education/special-education/
http://online.cuw.edu/online-degrees/master-of-science-in-education/teaching-learning/
http://online.cuw.edu/online-degrees/master-of-science-in-special-education-learning-disabilities/
http://online.cuw.edu/online-degrees/masters-of-science-in-education-family-life/
http://online.cuw.edu/programs/graduate/educational-leadership/
http://online.cuw.edu/programs/graduate/literacy/
http://online.cuw.edu/programs/graduate/special-education/
http://online.cuw.edu/programs/graduate/teaching-learning/
http://onlineinfo.cuw.edu/go/7-key-ideas-lutheran-school-administrators/
http://onlineinfo.cuw.edu/go/career-consultation/
http://onlineinfo.cuw.edu/go/curriculum-instruction/
http://onlineinfo.cuw.edu/go/education-degrees/
http://onlineinfo.cuw.edu/go/education-technology/
http://onlineinfo.cuw.edu/go/educational-leadership/
http://onlineinfo.cuw.edu/go/educator-quiz/
http://onlineinfo.cuw.edu/go/general-accelerated/
http://onlineinfo.cuw.edu/go/ms-counseling/
http://onlineinfo.cuw.edu/go/ms-education-literacy/
http://onlineinfo.cuw.edu/go/ms-educational-administration/
http://onlineinfo.cuw.edu/go/ms-special-education/
http://onlineinfo.cuw.edu/go/ms-teaching-and-learning/
http://onlineinfo.cuw.edu/strengthsfinder-for-teachers
https://www.cuw.edu/programs/ed-admin/index.html
https://www.cuw.edu/programs/educationtech/index.html
https://www.cuw.edu/programs/familystudies/index.html
https://www.cuw.edu/programs/literacy/index.html
https://www.cuw.edu/programs/specialeducation/index.html
https://www.cuw.edu/programs/teachlearn/index.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);