import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"(?:[^\"\\\\]|\\\\.)*\")|('(?:[^'\\\\]|\\\\.)*')|[\\S]+";
final String string = "set foo \"bar\\\" baz\" asdflkj\n"
+ "set foo 'bar\"\" baz' # this is a comment\n"
+ "set foo 'bar # nested comment'\n"
+ "set foo \"bar'\"asdfasdf\"' baz\"\n\n"
+ "set foo 'bar \"boom \\'clap\\'\" baz'; get foo";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}