# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?(\d+)[^\r\n\d]*$"
test_str = ("2^64\n"
"asdgaf1_hsg534\n"
"asdfh23_hsjd12\n"
"dgshg_jhfsd86\n"
"test\n"
"1\n"
"testing 1234 testing 1 test\n"
"testing 1234 testing 123")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.