$re = '/^\p{L}+\s+\p{L}+$/m';
$str = 'Désiré Müller
Désiré Müller';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);