re = /(?:\: )(?P<URL>.*)/
str = '![enter image description here][1] [1]: http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png'
# Print the match result
str.match(re) do |match|
puts match.to_s
end