using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(`)([\w]+)`|(\*)([\w]+)\*";
string input = @"`hel*low`orl* *hello* `world`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}