package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[+]\d+(?:[ ]\d+)*)`)
var str = `+33 10 69903282`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}