$re = '/^(?=.*?(pin))(?=.*?(kit))/m';
$str = 'bla bla pin, et encore du bla bla skit
Sinon kit d\'abord, puis pin
seulement le premier kit
Ici seulement pin
Ni le premier ni le second';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);