package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{(?:{[^{}]*}|[^{}])*}`)
var str = `aaa{bbb}ccc{ddd{eee}fff}ggg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}