re = /{{\s*\K[^}]+?(?=\s*}})/m
str = '{{SOME_STRING}}
{{ SOME_STRING}}
{{ SOME_STRING }}
{{ SOME-STRING }}
{{ SomE STRING }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end