#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$(?:(\[)|(\()|({)|(\/)).*?(?:(?=\2)(?=\3)(?=\4)\]|(?=\1)(?=\3)(?=\4)\)|(?=\1)(?=\2)(?=\4)}|(?=\1)(?=\2)(?=\3)\/)"
Local $sString = "// Matches" & @CRLF & _
"${...}" & @CRLF & _
"$(...)" & @CRLF & _
"$[...]" & @CRLF & _
"$/.../" & @CRLF & _
"// Does Not Match" & @CRLF & _
"${...)" & @CRLF & _
"${...]" & @CRLF & _
"${.../" & @CRLF & _
"$(...}" & @CRLF & _
"$(...]" & @CRLF & _
"$(.../" & @CRLF & _
"$[...}" & @CRLF & _
"$[...)" & @CRLF & _
"$[.../" & @CRLF & _
"$/...}" & @CRLF & _
"$/...)" & @CRLF & _
"$/...]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")