import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{4}:\\w{4}:\\w{4}|\\w{2}:\\w{2}:\\w{2}:\\w{2}:\\w{2}:\\w{2})";
final String string = "a0b1:ff33:acd5 ghwvauguvwi ybvakvi\n"
+ "klasilvavh; 11b9:33df:55f6\n"
+ "haliviv\n"
+ "a4d1:e733:ff55\n"
+ "66a1:b2f3:b9c5\n"
+ "a0:b1:c2:d3:e5:f6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}