$re = '/(?<!, |,|^)"(?!,|$)/m';
$str = '"Testing","Test123", ""Test0202" else", "Test 223 "testing" end" "Orange", "Banana", ""apple" crown", "tasty "Grapes" end"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);