re = /\/\*[^*]*(?:\*(?!\/)[^*]*)*\*\//
str = '/* Multi-line\\n\\
*
* comment */'
# Print the match result
str.match(re) do |match|
puts match.to_s
end