$re = '/[^a-zA-Z0-9\']+|\s+/';
$str = '"Hello can\'t world, how are [you! (today)? "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);