$re = '/(?<=\btrackingID\b=)(\s*[^;\r\n]*)|\\\\"code\\\\":\\\\"([^\\\\"\r\n]*)|(\\\\"status\\\\"):(\d*)|\\\\"msg:([^\\\\"\r\n]*)/m';
$str = 'ErrorString : trackingID=jskdf-77sdkj-oij4-kerj43-lklfds; key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"messages\\":\\"msg:INVALID_ERROR\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"$httpStatus\\":400},\\"status\\":400,\\"test\\":\\"ABC2342fdsff3\\"
ErrorString : key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"$httpStatus\\":400},\\"messages\\":\\"msg:INVALID_ERROR\\",\\"status\\":400,\\"test\\":\\"ABC2342fdsff3\\"trackingID=jskdf-77sdkj-oij4-kerj43-lklfds;
ErrorString : trackingID=jskdf-77sdkj-oij4-kerj43-lklfds; key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"status\\":400,\\"$httpStatus\\":400},\\"messages\\":\\"msg:INVALID_ERROR\\",\\"test\\":\\"ABC2342fdsff3\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);