$re = '/(^(\w*?,){0,3}\w*$|^(\w*?,){5,}\w*$)/m';
$str = 'abcd,efg,hi,jk,a
abd,fef,rgr,ht
abd,aad,rhrhr,rtre
dfsf,sdf,sfsdf,sdfs
dfsf,sdf,sfsdf,sdfs,nnn
dfsf,sdf,sfsdf,sdfs
dfsf,sdf,sfsdf,sdfs,aorsient,aoiresnt,aorsein';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);