$re = '/^(?:[3-5789]\d{8})$/x';
$str = '512345678';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);