use strict;
my $str = 'This is the entire article....Fishing vessel crews are almost entirely male, yet women make up a large proportion of workers on the land, mending nets or picking shellfish from sand. This is the sentence I want to exclude which contains BBB on it but text goes on without exclude anything else also the specific sentence changes from txt files just the word BBB stay inside it so on each file the sentence will be different.. Just the As co-founder of Women In The Food Industry, I was curious as to why this was the case, so asked several women in the seafood market why they felt this pattern has continued into the 21st century and to share their thoughts on how we might improve the visibility of women in the seafood industry.';
my $regex = qr/([.?!])[^.?!]*?BBB[^.?!]*?[.?!]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";