$re = '/(?:\d+\.\d+)/';
$str = 'var initialPrice = " $250.00" // I need just 250B00
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);