package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`want\s*(\+\d+)`)
var str = `This is the number I want +2143334 !, again this is the next number I want +234343443 !, last number I want +76645 !, fininshed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}