const regex = /\[[^\]]+]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[^\\]]+]', 'gm')
const str = `[01]ABC0007[0d0a]BB BABLOXC[0d0a]067989 PLPXBNS[0d0a02]BBR OIC002 L5U0/P AMD KAP 041800 T1200AND 2+00[0d0a0b03]`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);