$re = '/F.*(?<=s\s)|F.*\n\S+/m';
$str = 'This is a Fai - airies example
This is a Fa- 8 -
iries example
Another Fai-ries story';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);