use strict;
my $str = 'http://www.youtube.com/user/TheJuicyJVEVO
https://www.youtube.com/channel/UC4SusBgD3b1G5cCh_gjA81g
http://www.youtube.com/user/fabrikaband?gl=RU&hl=ru
https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/featured
https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/videos?a=b&b=c
https://www.youtube.com/duranduran
https://www.youtube.com/r3hab';
my $regex = qr/com\/(?:.*?\/)?([\w\d]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}