#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)com/(?:[^/]+/)?\K[^/\s?]+"
Local $sString = "http://www.youtube.com/user/TheJuicyJVEVO" & @CRLF & _
"https://www.youtube.com/channel/UC4SusBgD3b1G5cCh_gjA81g" & @CRLF & _
"http://www.youtube.com/user/fabrikaband?gl=RU&hl=ru" & @CRLF & _
"https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/featured" & @CRLF & _
"https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/videos?a=b&b=c" & @CRLF & _
"https://www.youtube.com/duranduran" & @CRLF & _
"https://www.youtube.com/r3hab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")