#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Country of origin Index.*\n)(?:(?!ROBERTO)(?!Country of origin)[\s\S\n])*"
Local $sString = "ROBERTO S.R.L. " & @CRLF & _
"Automotive Aftermarket" & @CRLF & _
"ROBERTO S.R.L., Str. Horia Macelariu nr. 30-34, RO-013937 Bucuresti" & @CRLF & _
"Capitalul Social: 169.363.000 Lei, Nr. Ord. Reg. com.: J40/7601/1994 " & @CRLF & _
" " & @CRLF & _
"Citibank Europe Plc Dublin, Romania Branch Citibank Europe Plc Dublin, Bulgaria Branch " & @CRLF & _
"SWIFT CODE: CITIROBU SWIFT CODE: CITIBGSF " & @CRLF & _
"IBAN RON: RO45 CITI 0000 0007 2488 3001 IBAN BGN: BG54 CITI 9250 1001 0086 00 " & @CRLF & _
"IBAN EURO: RO48 CITI 0000 0007 2488 3044" & @CRLF & _
"Invoice 1/ 2" & @CRLF & _
"Document No.: 2045158199" & @CRLF & _
"Date: 20.05.2022" & @CRLF & _
"Sold To party: 95100938" & @CRLF & _
"Account No.: 95100938" & @CRLF & _
"ALFREDO GIOACCHINO OOD " & @CRLF & _
"ul. Andrey Germanov 11 " & @CRLF & _
"BG-1336 SOFIA" & @CRLF & _
"Your VAT No.: BG175423111" & @CRLF & _
"Our VAT No.: RO5541546" & @CRLF & _
"Contact Person Finance: VALENTINA IVANOVA" & @CRLF & _
"Phone: +35929601062" & @CRLF & _
"E-mail: Valentina.Ivanova@bg.bosch.com" & @CRLF & _
"Contacts: IVA GYONEVA" & @CRLF & _
"Phone: +359029601056" & @CRLF & _
"E-mail: external.Iva.Gyoneva@bg.bosch.com" & @CRLF & _
"Sold To Address: ALFREDO GIOACCHINO OOD, ul. Andrey Germanov 11, BG-1336 SOFIA, B" & @CRLF & _
"Item Material/Description Quantity Unit Price per unit Net Value BGN" & @CRLF & _
"Transport: 1180736236 Shipping Point: ADC/LDC DE, Karlsruhe Shipping Type: Truck" & @CRLF & _
"Ship To Party: 95100938 ALFREDO GIOACCHINO OOD " & @CRLF & _
"ul. Andrey Germanov 11 " & @CRLF & _
"BG-1336 SOFIA" & @CRLF & _
"Delivery No.: 822656882 Delivery Date: 27.05.2022 Delivery Type: Standard Order AA" & @CRLF & _
"Your Order No.: 20220420-132109-436R From: 20.04.2022 Our Order No.: 15402739" & @CRLF & _
"10 Nozzle And Holder Assy 6 EA" & @CRLF & _
"Material: 0.432.191.301.741" & @CRLF & _
"Material Entered: 0.432.191.301" & @CRLF & _
"EAN: 3165143436226" & @CRLF & _
"82,32 493,92" & @CRLF & _
"Dispatch element: 105755352 6 EA" & @CRLF & _
"Your Order No.: 20220509-135611-091G From: 09.05.2022 Our Order No.: 210012705" & @CRLF & _
"20 Nozzle And Holder Assy 6 EA" & @CRLF & _
"Material: 0.432.191.301.741" & @CRLF & _
"Material Entered: 0.432.191.301" & @CRLF & _
"EAN: 3165143436226" & @CRLF & _
"82,32 493,92" & @CRLF & _
"Dispatch element: 105755352 6 EA" & @CRLF & _
"Your Order No.: 20220513-121235-468D From: 13.05.2022 Our Order No.: 210024679" & @CRLF & _
"30 mechanical steering pump 2 EA" & @CRLF & _
"Material: K.S00.000.394.002" & @CRLF & _
"Material Entered: K.S00.000.394" & @CRLF & _
"EAN: 4047025443456" & @CRLF & _
"565,00 1.130,00" & @CRLF & _
"Dispatch element: 105755352 2 EA" & @CRLF & _
"Total net value: 2.117,84" & @CRLF & _
"VAT:* Z9 0,00 % 2.117,84 0,00" & @CRLF & _
"Invoice amount: 2.117,84" & @CRLF & _
"* Triangular transaction taxable at the customer according to Art. 141, 2006/112/EC" & @CRLF & _
"Incoterms: DAP SOFIAROBERTO S.R.L. " & @CRLF & _
"Automotive Aftermarket" & @CRLF & _
"ROBERTO S.R.L., Str. Horia Macelariu nr. 30-34, RO-013937 Bucuresti" & @CRLF & _
"Capitalul Social: 169.363.000 Lei, Nr. Ord. Reg. com.: J40/7601/1994 " & @CRLF & _
" " & @CRLF & _
"Citibank Europe Plc Dublin, Romania Branch Citibank Europe Plc Dublin, Bulgaria Branch " & @CRLF & _
"SWIFT CODE: CITIROBU SWIFT CODE: CITIBGSF " & @CRLF & _
"IBAN RON: RO45 CITI 0000 0007 2488 3001 IBAN BGN: BG54 CITI 9250 1001 0086 00 " & @CRLF & _
"IBAN EURO: RO48 CITI 0000 0007 2488 3044" & @CRLF & _
"Invoice 2/ 2" & @CRLF & _
"Document No.: 2045158199" & @CRLF & _
"Date: 20.05.2022" & @CRLF & _
"Sold To party: 95100938" & @CRLF & _
"Account No.: 95100938" & @CRLF & _
"Payment terms: Up to 03.06.2022 you receive 2,000 % discount" & @CRLF & _
"Up to 19.06.2022 without deduction" & @CRLF & _
"Country of origin Index (represents the last three digits of part number)" & @CRLF & _
"Brazil 741" & @CRLF & _
"Germany 002" & @CRLF & _
"Country of origin HS Code Quantity UoM Amount BGN" & @CRLF & _
"Brazil" & @CRLF & _
"84099900 12 EA 987,84" & @CRLF & _
"987,84" & @CRLF & _
"Germany" & @CRLF & _
"84136061 2 EA 1.130,00" & @CRLF & _
"1.130,00" & @CRLF & _
"Marking Dispatch element type Physical dimension of dispatch " & @CRLF & _
"element" & @CRLF & _
"Unit of " & @CRLF & _
"measure" & @CRLF & _
"Gross " & @CRLF & _
"Weight Unit of measure" & @CRLF & _
"105755352 Corrug. brown box RB-logo 550X35 550 350 300 MM 14,880 KG" & @CRLF & _
"Country of origin Item numbers Total amount" & @CRLF & _
"Brazil 10 20 987,84" & @CRLF & _
"Germany 30 1.130,00" & @CRLF & _
"Element type: Corrug. brown box RB-logo 550X35Number of elements: 1 14,880 KG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")