import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "alt.+?(?= src)";
final String string = "<img alt=\"\" border=\"0\" width=\"320\" data-original-height=\"2448\" data-original-width=\"3264\" src=\"https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEioWN9OlO4KRxREJkSozaN1rB0DlDTEnMnO5yh3zzeR-ipfXsoQC2KIjOA6_HzNBqqzhS6UxAaobig49GlOFaI7-P5jHmibtpmBJW6iuLrHcYtdC6Em6RWNzIOlfshFkpDgv_jE5VcHet5xxxYE9eZJ157b-bytHBq4pA78kPdoUeXn9o55eHa4OjPE_g/s320/1670258048910-01.jpeg\"/>\n"
+ "<img alt=\"\" border=\"0\" width=\"320\" data-original-height=\"3472\" data-original-width=\"4624\" src=\"https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEgmJSEhOjEIyY-T0IYWeyPqFxWL14L6rhbR733dI9wm0tvVSKXtRU0iC2FkNxKgprqUUtiLG6PFyGZ-pSWsPNuH99VQsn-O3zPeZvIGRUIY7Y-lIYiFeAhLAGhXVQZE-FGWQ8ep4wpzbCanwI-SlphDIKkB9gzgEXfLyw1uQ9iwDDAGOXLINasbRCxADA/s320/1670267239853-01.jpeg\"/>";
final String subst = "border=\"0\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}