$re = '/(\/)(?=\*)(?:\*)((?:\1|[\s\S])*?)(?:\*)\1|(?=(\/\/)([\s\S]*))/m';
$str = '/*
something
*/
/* something */
/*
* // something
*
*/
/*/something/*/
// teste';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);