$re = '/(\b[0-9]+\b)/m';
$str = '14996, 14993, 14988, 14987, 14987, 14984, 15430';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);