$re = '/^(?:^|[^x])x(?!x)/m';
$str = 'x
xx
xxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);