$re = '/(?<=[A-Z])(?=[A-Z][a-z])|(?<=[^A-Z])(?=[A-Z])/m';
$str = 'CostCenter
FYYear
ANotherTest
ANDAnotherTest
upperCase
UpperCase';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);