$re = '/(0[1-9]|[1-2][0-9]|3[0-1]).(0[1-9]|1[1-2]).\d{4}\s([0-1][0-9]|2[0-3]).[0-5][0-9]/i';
$str = '30.12.2001 23.59';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);