const regex = /<svg[^>]+>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<svg[^>]+>', 'gmi')
const str = `<!-- Generator: Adobe Illustrator 23.0.2, SVG Export Plug-In -->
<svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="53.5px"
height="42.8px" viewBox="0 0 53.5 42.8" style="enable-background:new 0 0 53.5 42.8;" xml:space="preserve">
<style type="text/css">
.st0{fill:#C49039;}
</style>
<defs>
</defs>
<path class="st0" d="M53.5,21.4C53.5,8.6,44.2,0,28.4,0H0v42.8h28.4C44.2,42.8,53.5,33.9,53.5,21.4z"/>
</svg>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);