$re = '/\B(?=AB|\d)/m';
$str = '11AB2AB33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);