# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Z][A-HJ-Y]?\d[A-Z\d]? ?\d[A-Z]{2}|GIR ?0A{2})$"
test_str = ("A1A 1AA\n"
"A1 1AA\n"
"A11 1AA\n"
"AA1 1AA\n"
"AA1A 1AA\n"
"AA11 1AA\n"
"A1A1AA\n"
"A11AA\n"
"A111AA\n"
"AA11AA\n"
"AA1A1AA\n"
"AA111AA\n"
"GIR 0AA\n"
"GIR0AA\n"
"a1a 1aa\n"
"a1 1aa\n"
"a11 1aa\n"
"aa1 1aa\n"
"aa1a 1aa\n"
"aa11 1aa\n"
"a1a1aa\n"
"a11aa\n"
"a111aa\n"
"aa11aa\n"
"aa1a1aa\n"
"aa111aa\n"
"gir 0aa\n"
"gir0aa")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.