# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([A-Z][A-HJ-Y]?\d[A-Z\d]?|ASCN|STHL|TDCU|BBND|[BFS]IQQ|PCRN|TKCA) ?\d[A-Z]{2}|BFPO ?\d{1,4}|(KY\d|MSR|VG|AI)[ -]?\d{4}|[A-Z]{2} ?\d{2}|GE ?CX|GIR ?0A{2}|SAN ?TA1)$"
test_str = ("AI-1111\n"
"ASCN 1ZZ\n"
"STHL 1ZZ\n"
"TDCU 1ZZ\n"
"BBND 1ZZ\n"
"BIQQ 1ZZ\n"
"FIQQ 1ZZ\n"
"GX11 1ZZ\n"
"PCRN 1ZZ\n"
"SIQQ 1ZZ\n"
"TKCA 1ZZ\n"
"BFPO 11\n"
"ZZ 11\n"
"GE CX\n"
"KY1-1111\n"
"VG1111\n"
"MSR 1111\n"
"A1A 1AA\n"
"A1 1AA\n"
"A11 1AA\n"
"AA1 1AA\n"
"AA1A 1AA\n"
"AA11 1AA\n"
"A1A1AA\n"
"A11AA\n"
"A111AA\n"
"AA11AA\n"
"AA1A1AA\n"
"AA111AA\n"
"GIR 0AA\n"
"GIR0AA\n"
"BFPO 1\n"
"BFPO 11\n"
"BFPO 111\n"
"BFPO 1111\n"
"SAN TA1")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.