use strict;
my $str = '004frac{0030900000}{001}';
my $regex = qr/(\D|^)0+(?=\d)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";