import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^)\\bANNA\\w+\\b(?!$)";
final String string = "Lorem ipsum dolor sit amet ANNA_END\n"
+ "ANNA_BEGIN lorem ipsum dolor sit amet\n"
+ "Lorem ipsum dolor ANNA_MIDDLE sit amet";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}