// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)?(d\d+)?(dl\d+)?(dh\d+)?").unwrap();
let string = "1d5
d7
5
7d5dl2
6d1dh4
d1dl9dh1
4dl1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}