re = /^(?P<begin>\d{2}\/\d{2}\/\d{4})\s\-\s(?P<end>\d{2}\/\d{2}\/\d{4})$/m
str = '08/17/2020 - 08/23/2020'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end