import re
regex = re.compile(r",(?!\d+\))", flags=re.MULTILINE)
test_str = "Id uniqueidentifier null2,2version varchar(50) null,Modified datetime null,ModifiedBy uniqueidentifier null,Created datetime null,CreatedBy uniqueidentifier null,Folder_Id uniqueidentifier null,Currency_Id uniqueidentifier null,RefCurrency_Id uniqueidentifier null,ValidFrom datetime null,ValidTo datetime null,Rate decimal(28,18) null,"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")