const regex = /(\[\w+)\.(?=\w+])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[\\w+)\\.(?=\\w+])', 'g')
const str = `I am parsing some SQL statements and have found places where the SELECT statement may be:
SELECT [tblCustomer].[FirstName], [tblCustomer.LastName], [tblOrder].[Order_No]
Another example:
SELECT IIf([tbl_ref_Service].[Root_Service] Is Null,[tbl_ref_Service].[Service],[tbl_ref_Service].[Root_Service]) AS Root_Service, tbl_POC_Assigned.POC_ID, [tbl_POC_Assigned.Hex_ID] & "_" & [tbl_Hex.Generic_ID] & "_" & [tbl_Lateral.Service_ID] & "_" & [tbl_Hex.ODD_Micap] & "_Null" AS Tool_Generic_Line, tbl_Hex.Building_ID AS Hex_Building_ID, tbl_POC.Lateral_ID, tbl_Generic_Service.Peak_Flow, [Diversity_Factor]*[Peak_Flow] AS Avg_Flow, tbl_POC_Assigned.Flow, tbl_POC_Assigned.Flow_Avg`;
const subst = `$1].[`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);