import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<parameter>[^:]+)\\:\\s*(?:(?<value>[A-Za-z]+\\:\\s*[^>]+))\\s*(?<description>.*)";
final String string = "pts_time: PTS: 1741047514> Time: 19345 sec > (hh:mm:ss.ms) 05:22:24.972\n"
+ "pts_time: PTS: 1741047514 [0x67C646DA] > Time: 19345 sec > (hh:mm:ss.ms) 05:22:24.972\n"
+ "private_indicator: '0' reserved: '11'\n"
+ "section_length: 0x39 (57) protocol_version: 0\n"
+ "encrypted_packet: 0 no part of this message is encrypted\n"
+ "encryption_algorithm: 0 No encryption\n"
+ "pts_adjustment: 0xFFFF7F18 (33000) > Time: 95443.4 sec > (hh:mm:ss.ms) 26:30:43.351\n"
+ "cw_index: 0x00 (0) tier: 0x0FFF (4095)\n"
+ "splice_command_length: 0x0005 (5) splice_command_type: 0x06 (6) time_signal [] time_signal: > Time: 19345 sec > (hh:mm:ss.ms) 05:22:24.972\n"
+ "time_specified_flag: 1 presence of the pts_time field\n"
+ "reserved: 0x3F (63) descriptor_loop_length: 35 [] Descriptors: [] segmentation_descriptor (0x02): Content Identification (0x01)\n"
+ "descriptor_tag: 0x02 (2) descriptor_length: 0x21 (33)\n"
+ "identifier: 0x43554549 (CUEI) segmentation_event_id: 0x00000001 (1)\n"
+ "segmentation_event_cancel_indicator: '0' a previously sent segmentation event, identified by segmentation_event_id, has NOT been cancelled\n"
+ "reserved: 0x7F (127) program_segmentation_flag: '1' the message refers to a Program Segmentation Point and that the mode is the Program Segmentation Mode whereby all PIDs/components of the program are to be segmented\n"
+ "segmentation_duration_flag: '0' No presence of segmentation_duration field\n"
+ "delivery_not_restricted_flag: '1' the next five bits are reserved\n"
+ "reserved: 0x1F (31) segmentation_upid_type: 0x01 (1) Deprecated: use type 0x0C; The segmentation_upid does not follow a standard naming scheme.\n"
+ "segmentation_upid_length: 0x12 (18) segmentation_type_id: 0x01 (1) Content Identification\n"
+ "segment_num: 0x01 (1) segments_expected: 0x01 (1)\n"
+ "CRC_32: 0x46D15AF3 CRC OK\n\n"
+ "// try this one first\n"
+ "// (a) ^(?<parameter>[^:]+)\\:\\s*(?:(?<value>[A-Za-z]+\\:\\s*[^>]+))\n"
+ "// (b) ^(?<parameter>[^:]+)\\:\\s*(?:(?<value>[A-Za-z]+\\:\\s*[^>]+))\\s*(?<description>.*)\n\n"
+ "// in case of no match of the above one use the second\n"
+ "// (a) ^(?<parameter>[^:]+):\\s*(?<value>[\\w']+(?:\\s*\\([^)]*\\))*)\n"
+ "// (b) ^(?<parameter>[^:]+):\\s*(?<value>[\\w']+(?:\\s*\\([^)]*\\))*)\\s*(?<description>.*)\n\n"
+ "// substitution:\n"
+ "// [\"$1\", \"$2\", \"$3\"]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}