re = /\b(\w+)\b(?=(?:\s*[^\w\s]\s*\w+)+\s*[^\w\s]\s*\b\1\b)/m
str = 'item1 , test, item3 ;
item4,item5;
test , item6;
alex , alex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end