const regex = new RegExp('(object-group service (?P<name>.+)(?:\\n |.)|service-object (?P<protocol>.+) destination eq (?P<port_no1>\\d{0,5} |\\w{0,10}.+)\\n|service-object (?P<protocol2>object) (?P<port_no2>\\d{0,5} |\\w{0,10}.+)\\n)', 'gm')
const str = `object-group service DM_INLINE_SERVICE_8
service-object tcp destination eq ldap
service-object udp destination eq syslog
service-object object kerberos5-tcp
service-object object kerberos5-udp
service-object object ldap-udp
service-object udp destination eq domain
service-object object ldap-gcs
service-object object TCP_3268
service-object object TCP_3269
service-object object TCP_445
service-object tcp-udp destination eq domain
service-object tcp destination eq ldaps
service-object udp destination eq ntp
service-object object TCP_464
object-group network DM_INLINE_NETWORK_13
network-object object IN_V030_197_memcache_01
network-object object IN_V030_198_memcache_02
object-group service DM_INLINE_SERVICE_9
service-object tcp destination eq ldap
service-object udp destination eq syslog
service-object object kerberos5-tcp
service-object object kerberos5-udp
service-object object ldap-udp
service-object udp destination eq domain
service-object object ldap-gcs
service-object object TCP_3268
service-object object TCP_3269
service-object object TCP_445
service-object tcp-udp destination eq domain
service-object tcp destination eq ldaps
service-object udp destination eq ntp
service-object object TCP_464
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}